Installing libpcap with Napatech Extensions

libpcap Installation

product_line_custom
IntelĀ® PAC
Napatech SmartNIC
category
Software Installation Guide

About this task

Tip: You can use the package_install_3gd-x.y.z.sh script described in DN-0379 and DN-0393 to install Napatech libpcap, instead of using the procedure in this section.

Before you begin

It is a prerequisite for installing Napatech libpcap that an NT driver package is installed (see DN-0379 or DN-0393).

The following are required in order to build and install libpcap:
  • GCC version 4.0 or later
  • GNU make
  • flex and bison or lex and yacc. Some versions of lex are insufficient to compile libpcap; if this is the case, install flex and bison.

Steps

To install libpcap with Napatech extensions:

Procedure

  1. Download the product package for your operating system from supportportal.napatech.com (the Napatech Support Portal).
  2. Expand the product package archive and enter the ntanl_package_3gd-x.y.z-linux/pcap directory:
    $ tar xzf ntanl_package_3gd-x.y.z-linux.tar.gz
    $ cd ntanl_package_3gd-x.y.z-linux
    $ cd pcap
  3. Enter the nt_libpcap_x.y.z directory:
    $ tar xfz nt_libpcap_x.y.z.tar.gz
    $ cd nt_libpcap_x.y.z
  4. Determine which version of libpcap with Napatech extensions that you want to install. Refer to the README file for more information about available versions.
    $ less README
    $ cd libpcap-x.y.z
  5. Configure for installation in the Napatech driver installation directory:
    $ ./configure --prefix=/opt/napatech3
  6. To install the libpcap static and shared library, execute the following command:
    For FreeBSD:
    $ sudo gmake install
    For Linux:
    $ sudo make install
  7. To update ldd cache, execute the following command:
    $ sudo ldconfig -f /etc/ld.so.conf